2006年9月14日

VoIPが使えない(upnpd: Error registering the rootdevice : -202)

VoIPが使えなくなった.
syslogを見てみると, upnpdが
Error registering the rootdevice : -202
というエラーを吐いている.

これが原因か?
とはいえ, upnpd(linux-igd)関連のファイルは
かなり前から変更していないのに.
しかも, VoIPが使えていた時期にも, -202のエラーは
時々出ていた.

syslogのupnpdのログを追いかけてみると, kernelを
gcc 4.1.1でコンパイルして再起動した後からは,
upnpdを起動するたびに-202エラーが出ていることが判明.
gcc 4.1.1への移行がまずかったのかな...

それでも, 今までVoIPは使えていたのに, なぜ, 突然....???

同じ症状がgentoo.orgでも報告されていた.
linux-igd-0.92: "upnpd: Error registering the rootdevice : -202"
http://bugs.gentoo.org/show_bug.cgi?id=119862


解決方法のひとつは, linux-igd 0.95を使用すること.

続きを読む "VoIPが使えない(upnpd: Error registering the rootdevice : -202)"

2006年9月 3日

デジタルビデオカメラ

デジタルビデオカメラを買った.
HDDのモノがいいかなといろいろと悩み, SONYブランドが
気に入らなかったが, DCR-SR100を購入.
近所のコジマで, 追加バッテリーと一緒に買って, 本体部分を
\99,000-にしてもらった.

おもちゃができて楽しい一日. (^_^)

Coolpix 5700がまた壊れた

今年の年始にも壊れ, 友人の結婚式の写真を取ることができなくなった
Coolpix 5700がまた壊れた. 今回で3回目.

購入したサトームセンに持って行くと, 修理に3週間から1ヶ月は軽くとられる.
おまけに, 代替機も貸し出してもらえないので, 今回は, 新宿のサービスセンターに
連絡を取り, 代替機を貸してもらえるように調整した上で, 持って行った.

が, 修理に2万円ほどかかる見込み. サトームセンに持って行けば延長
保証があるので, 無償で直してくれる.
いろいろと考えたあげく, 修理するのをやめることに.
フラッシュを発行禁止にしておけばちゃんと写真を撮ることができるし,
2万円+1?万円出せば, D80くらいには手が届くし.

にしても, Coolpix 5700壊れすぎ...

続きを読む "Coolpix 5700がまた壊れた"

Mi goreng

オーストラリアで暮らしていたときに一番おいしいと感じた
インスタントヌードルMi goreng.
日本で売れば売れるだろうなと思っていた. でも売っていない...

と思っていたら, 吉祥寺のKALDIに売っていた.
早速買ってきて食べてみた.
調味料が昔と変わっている気がするが, やっぱりうまかった.

ちなみに, 今の調味料は
・粉末ソース
・唐辛子?などのchilliなモノ
・2種類の油

以前は, chilliがなくて, かわりに3種類の油だったような....

2006年9月 2日

携帯電話番号ポータビリティのお値段

携帯電話番号ポータビリティ(MNP)の手数料が出そろったようだ.
各社とも, 転出時に2000円のみの課金.
なお, 転入時は通常の契約開始と同じように事務手数料はかかる.

参考
au: http://www.kddi.com/corporate/news_release/2006/0809a/index.html
docomo: http://www.nttdocomo.co.jp/info/news_release/page/20060829.html
softbank: http://www.vodafone.jp/japanese/release/2006/20060831j.pdf

2006年9月 1日

gcc 3.4.6→4.1.1

GentooのemergeでGCC 4.1.x系が利用できるようになったので,
早速アップデート.

Gentoo Linux GCC Upgrade GuideどおりにやればOK
http://www.gentoo.org/doc/en/gcc-upgrading.xml

# emerge -u gcc
# gcc-config i686-pc-linux-gnu-4.1.1
# source /etc/profile
# fix_libtool_files.sh 3.4.6
# emerge --oneshot -av libtool
# emerge -e system
# emerge -e world
# emerge -aC =sys-devel/gcc-3.4*

途中, app-i18n/kccのコンパイルができなかった.
gcc 3.x系から発生している<varargs.h>が存在しない問題.
パッチに関しては, こちらを参照.